Toyota Camry steering lock ECU trouble and can’t start

A driver’s Toyota Camry can’t start by smart key, and I confirm it isn’t interfered, the starting machine can work, sometimes it can start the car, sometimes it will flameout after start, after the starting button is pressed it has no reaction, and after depress the brake pedal, the ignition switch indicator not flash, Rear brake lights flash and the safe indictor light on and off in normal situation. According to the above symptoms, I judge the following parts have fault: shutdown system ECU, associated wiring harness, relay, starting button and other parts.
Trouble diagnosis: firstly, I use Toyota IT2 to read out trouble code, it is B2799: Engine Immobilizer Malfunction, then clear it and start the vehicle again, it still exist trouble code. Then I search maintenance manual and the possible reason is wiring harness, ECM and ID box.

toyota-intelligent-tester-it2-1

Locking system and the related parts is too much and it is sophisticated to measure. Firstly, in another same car model I remove the ECM and a key button to test in this car, the trouble stay. In the process of trying to replace, I find new abnormal symptom, the steering has no lock / unlock function, if it has, then the car can start.

 

Steering lock system indicates: Steering lock ECU detect locking bar location (lock / unlock) and automatically transfer this inform to main ECU and the authorized ECU. Ensure whether authorized ECU follows main ECU communicating way to lock or unlock steering machine. Then authorized ECU send lock or unlock command signal to steering lock ECU by ID code.

 

It can be seen there are many sophisticated parts need to test. Then I connect IT2 to read data stream, it displays  Lck/UnlckRec (YES)steering lock ECU receive lock / unlock command. Then I use multimeter to test steering lock ECU wiring harness and find terminals E51-3 and E51-1 voltage is 0.21V (standard condition: the voltage is under 1V when the motor is running) when the ignition switch off and open the left door, then I test the same terminals on another same car model and the voltage become 10.59V within only several seconds (standard condition: the voltage is 10~12V when the motor is not running). But all the other terminals aredetected to meet the standard requirements.

 

Based on the test result, I infer steering lock ECU can’t active TV. Then I remove steering lock ECU and find a part of it was corroded, then I check its repairing history it was flooded 3 year ago, the driver used to replace all ECU except steering ECU.

 

After replace new steering lock ECU and finish matching, I encounter new trouble, when ignition switch turn to “ON” position, dashboard  has display, SRS indicator light keep flash, the starting machine fail to turn, remote control door lock smart enter function can work. After the old steering lock ECU is installed, the starting machine starts to turn, but later get the same trouble. I guess when I program, it produces new trouble. And I preliminarily judge the authorized ECU is damaged when it the key is matched, and the wiring harness maybe have faulty.
Again test the LIN cable among ID box, ECM, main ECU and authorized ECU,it is functioning. Connect Toyota IT2 to read main ECU, it displays G.SW-ACC.SW: ON, main ECU detects out ignition switch real location and display Immobilizer-SET key not in the car. Read from the above data stream, the authorized ECU not detects the key and ignition switch location. Check authorized ECU power and ground line conforms to the requirement. According to the above data and testing result, I speculate authorized ECU has faulty.

Because the special relevance between authorized ECU and ID box, then I order both authorized ECU and ID box. After the new parts arrive, again register to match key, after finish matching the safe indicator doesn’t flameout neither, the starting machine can’t work neither, the same result. Then I calm down and reflect where it has problem, then I find where the problem is, I instantly close ignition switch to OFF position, I use remote control to open / close lock, then enter the car to start, safe indicator flameout and the car can start. Several days later after the driver drive it home, I call the driver and everything is OK, it means the fault is completely fixed.

 

The reason which lead to authorized ECU has fault is that the ignition switch isn’t on OFF location and the ECU is in sleep state without active after the last-time programming. But after finish program it can’t start, then repeat replace new and old steering lock to match lead to authorized ECU broke.

(Visited 211 times, 1 visits today)