(Solved) ISTA+ failed to start after win10 32bit update

Issue:

Using ista+ 4.04.12 this machine had a working older version but it crashed and would no longer start.

 

Windows 10 32bit

Net framework 4.5.2 and 4.6.2 and vs90 are installed

ran unblock reg patch

deleted previous install

ran rcleaner as admin

un7’ed new one

ran standalone reg x86 patch

 

Advice by www.uobdii.com engineer: Did you also install all the VCRedist for x32? If not, open “VC Redist Links” document and install everything x32. If there was a log generated, it would be in ~:\Rheingold\Logs. Check and see if you can find anything off. Use Notepad++ to view the logs.

Also reinstall all the pre-requisites again (.NET, VS90, VC Redist) and see if that fixes it.

 

Logs generated:

Brand new windows 10 64bit install, followed install pdf, all the vc redists, had to add mscomctl.ocx to the install to enable bmw coding tools.

ista+ is a fail to start, here’s what the log shows:

2017-03-29 20:24:30 INFO [T] ISTA: [1] ConfigSettings.ConfigSettings() – called

2017-03-29 20:24:30 INFO [T] ISTA: [1] ConfigSettings.StoreAndLogChangedValue() – Change configuration “BMW.Rheingold.OperationalMode” from “ISTA” to “ISTA_PLUS” (read from “Configuration file”).

2017-03-29 20:24:30 INFO [T] ISTA: [1] ConfigSettings.ConfigSettings() – OperationalMode is ISTA_PLUS

2017-03-29 20:24:30 INFO [T] ISTA: [1] ConfigSettings.StoreAndLogChangedValue() – Change configuration “BMW.Rheingold.Logging.Directory” from “” to “..\..\..\Logs” (read from “Configuration file”).

2017-03-29 20:24:30 ERROR [T] ISTA: [1] App.App() – Failed to start ISTA:

System.TypeInitializationException: The type initializer for

‘BMW.Rheingold.CoreFramework.CoreFramework’ threw an exception. —>

System.IO.FileNotFoundException: Could not load file or assembly ‘RheingoldCoreBootstrap.dll’ or one of its dependencies. The specified module could not be found.

at BMW.Rheingold.CoreFramework.CoreFramework..cctor()

— End of inner exception stack trace —

at BMW.Rheingold.CoreFramework.CoreFramework.get_OSSM odeActive()

at BMW.Rheingold.ISTAGUI.App..ctor()

 

Solution:

Got it, one of my x86 vcredist icons looked weird I think it was corrupted I deleted it and redownloaded it now it works. On to ista-p.

Thanks to uobdii.com engineer.

(Visited 63 times, 1 visits today)